Excel WENN Funktion Titelbild

Excel WENN Funktion einfach erklärt

Die WENN Funktion in Excel, oder auch „Wenn Dann Funktion“, ist eine der am meisten verwendeten Funktionen in Excel. Sie ermöglicht Dir logische Vergleiche von Werten in Excel durchzuführen. Die WENN Funktion kann zwei mögliche Ergebnisse ausgeben, WAHR oder FALSCH. Fällt die Wahrheitsprüfung positiv mit WAHR aus, dann wird das erste Ergebnis ausgegeben. Schlägt die Prüfung jedoch fehl, also ist FALSCH, dann wird das zweite Ergebnis ausgegeben.

Anwendungsbereich und Beispiel zur WENN Funktion

Manchmal ist es erforderlich seine Daten auf bestimmte Eigenschaften zu überprüfen oder nach bestimmten Kriterien zu filtern. Mit der WENN Funktion lassen sich bestimmte Sachverhalte logisch überprüfen.

Beispielsweise kann so in einer sehr großen Tabelle eine weitere Prüfspalte erzeugt werden, dessen Wert auf einer WENN Funktion beruht. In diesem Artikel wird Dir die Excel WENN Funktion im Detail und an Hand von Beispielen einfach erklärt.

Excel WENN Funktion einfach erklärt

Beschreibung der Excel WENN Funktion

Die Excel WENN Funktion gehört zu der Kategorie der Logikfunktionen in Excel. Mit dieser Funktion kannst Du einen Wahrheitstest in Excel durchführen. Du definierst dabei eine Bedingung, die erfüllt sein muss, um ein bestimmtes Ergebnis auszugeben. Das ist immer der Fall, sobald die Bedingung erfüllt ist, somit WAHR ist. Wird die Bedingung nicht erfüllt, also wird mit FALSCH aus dem Wahrheitstest beantwortet, dann wird ein anderes Ergebnis ausgegeben.

Definition

Die Definition der WENN Funktion mag etwas umständlich erscheinen. So in etwa könnte die Funktionssyntax aus Excel etwas umgangssprachlicher beschrieben werden.

=WENN(ein Wert oder eine Bedingung WAHR ist; DANN tue etwas; andernfalls oder SONST tue etwas anderes)

Der Wahrheitswert der ganz vorne in der Funktion überprüft wird, kann also zwei Ausprägungen annehmen: WAHR oder FALSCH.

Man könnte die Excel WENN Funktion auch als eine „Wenn Dann Sonst Funktion“ beschreiben. Die WENN Funktion ist sehr mächtig und kann mit vielen anderen logischen Funktionen, wie zum Beispiel der ODER- sowie UND-Funktion, kombiniert werden. Genauso kann die Komplexität einer WENN Funktion mit verschachtelten WENN Funktionen erhöht werden.

Formelsyntax der WENN Funktion

Die Formelsyntax der Excel WENN Funktion sieht wie folgt aus:

=WENN(Wahrheitstest;[Wert_wenn_wahr];[Wert_wenn_falsch])

In älteren Excel Versionen wird auch die folgende Formelsyntax verwendet:

=WENN(Prüfung;Dann_Wert;[Sonst_Wert])

Die Variablen oder Argumente der Excel WENN Funktion lassen sich wie folgt beschreiben:

VariableBeschreibung
Wahrheitstest oder Prüfung (WENN)Hier wird eine Bedingung geprüft. Diese Bedingung oder dieser Wahrheitstest kann mit JA/WAHR oder NEIN/FALSCH beantwortet werden. Beispiel: Ist 1=1? (WAHR)
Wert wenn wahr / Dann Wert (DANN)Ist der Wahrheitstest mit JA oder WAHR zu beantworten, dann tue etwas, was hier definiert ist. Beispiel: Da 1=1 ist, liegt eine wahre Aussage vor. DANN schreibe bitte „Ja, 1 ist gleich 1“.
Wert_wenn_falsch / Sonst_Wert (SONST)Wenn der Wahrheitstest negativ, also FALSCH ausfällt, dann tue was hier beschrieben ist. Beispiel: Würde als Wahrheitstest „1=2“ überprüft werden, dann wäre dieses mit FALSCH zu beantworten oder „Das ist leider Falsch“.

Innerhalb der Wenn Funktion können auf verschiedenste Art und Weise Bedingungen geprüft werden. Du kannst Zellbezüge verwenden oder direkt in der Funktion Prüfungen formulieren. Sehr oft benötigst Du hier Vergleichsoperatoren wie das Gleichheitszeichen oder „Größer als“ (>) oder „Kleiner als“ (<). Genauso helfen Dir hier auch andere Funktionen wie die ODER- sowie UND-Funktion.

Einfache Beispiele zur Excel WENN Funktion

Das Anwendungsgebiet zur Excel WENN Funktion ist breit gefächert. Hier findest Du einige Beispiele zur Excel WENN Funktion aufgelistet.

Beispiel 1: Zahlenwert mit WENN vergleichen

In diesem Beispiel wird ein Wert in Zelle B3 ausgewertet. Wenn der Zellwert Eins beträgt, dann wird das Wort „Super“ zurückgegeben. Ist dem nicht so, dann steht „Nicht so toll!“ als Ergebnis in Zelle C3.

WENN Funktion Beispiel 1

Beispiel 2: Text mit WENN vergleichen

Beispiel 2 zeigt, wie mit der Excel WENN Funktion ein Text in einer Zelle überprüft. Enthält Zelle B3 das Wort „Super“, dann wird als Ergebnis der Wert Eins ausgegeben. Entspricht der Zellinhalt aber nicht dem Textwert „Super“, dann wird eine Neun ausgegeben.

WENN Funktion Beispiel 2

Die Excel WENN Funktion kann also zum Auswerten von Text und Werten verwendet werden. Genauso können auch andere Sachverhalte verglichen werden. Es können alle Vergleiche, Funktionen oder Werte in der WENN-Prüfung platziert werden, die als Ausgang ein WAHR oder FALSCH liefern. WAHR und FALSCH sind logische Werte.

Die WENN-Funktion kann sehr gut mit anderen logischen Funktionen wie der UND sowie ODER Funktion kombiniert werden. Das Anwendungsspektrum erweitert sich enorm, wenn Vergleichsoperatoren mit in die Funktion einbezogen werden. Bekannte Vergleiche sind zum Beispiel „Größer als“ (>) und Kleiner als (<) sowie das Gleichheitszeichen (=).

Beispiel 3: WENN mit der UND Funktion

Die UND Funktion prüft, ob alle Ihr übergebenen Argumente wahr sind. Ist das der Fall, dann wird der Wahrheitswert WAHR ausgegeben. Platziert man die UND Funktion als Prüfung in der WENN Funktion, dann können so mehrere Kriterien auf einmal geprüft werden.

Das folgende Beispiel zeigt eine Produkttabelle. In Spalte G und F wird geprüft ob es sich bei einem Produkt um gelbes Obst oder teures Gemüse handelt. Gelbes Obst zeichnet sich durch zwei Produkteigenschaften aus. Zum einen muss es sich um Obst handeln, zum anderen muss das Produkt gelb sein.

Trifft beides zu, dann handelt es sich um gelbes Obst. Analog wird teures Gemüse überprüft, indem geschaut wird ob der Preis größer als (>) 3,50 EUR ist und ob es sich bei dem Produkt um Gemüse handelt.

Die jeweiligen Rückgabewerte aus der Excel WENN Funktion sind als Text angegeben. Genauso könnte an gleicher Stelle eine Zahlenwert oder gar eine andere Funktion stehen.

WENN Funktion Beispiel 3

So funktioniert die Excel WENN Funktion

Excel WENN Funktion Anleitung

Die Excel WENN Funktion führt einen Test aus. Sie gibt ein Ergebnis bei WAHR und ein anderes bei FALSCH zurück. Um die WENN Funktion zu verwenden, ist eine Bedingung sowie mindestens eine Angabe für den Wert im Wahrheitsfall erforderlich.

Aufwand: 2 Minuten

  1. Funktionsname eingeben und Klammer öffnen

    Excel WENN Funktion Anleitung Schritt 1

    WENN Funktion eingeben: =WENN(

    Formeln starten immer mit einem Gleichheitszeichen und signalisieren Excel die Ausführung einer Rechenoperation. Die Excel WENN Funktion verlangt 3 Funktions-Argumente, welche in den nächsten Schritten erläutert werden.

  2. Wahrheitstest definieren

    Excel WENN Funktion Anleitung Schritt 2

    =WENN(Wahrheitstest;

    Beispiel: =WENN(B3=1;

    Die Wenn Funktion verlangt als erstes Argument einen Wahrheitstest oder eine Prüfung einer Bedingung. Diese kann in vielfältigen Ausführungen ausfallen. Hier können Werte anderer Zellen, Textvergleiche oder andere Vergleiche mit Hilfe von Vergleichsoperatoren oder anderen (logischen) Funktionen stattfinden. Es sind alle Ausdrücke zulässig die als Ergebnis die Ausprägung WAHR oder FALSCH annehmen können.

  3. Wert wenn WAHR definieren (DANN)

    Excel WENN Funktion Anleitung Schritt 3

    =WENN(Wahrheitstest;Wert_wenn_wahr;

    Beispiel: =WENN(B3=1;”Ja, B3 ist gleich 1″;

    Als zweites Argument der WENN Funktion wird der Ausgabewert für den WAHR-Wert definiert, also wenn die Bedingung aus dem Wahrheitstest positiv mit WAHR beantwortet werden kann. An dieser Stelle könnte auch eine Berechnung stattfinden oder gar eine weitere WENN Funktion eingefügt werden.

  4. Wert wenn FALSCH definieren (SONST)

    Excel WENN Funktion Anleitung Schritt 4

    =WENN(Wahrheitstest;Wert_wenn_wahr;Wert_wenn_falsch)

    Beispiel: =WENN(B3=1;”Ja, B3 ist gleich 1″;”Nein, in Zelle B3 steht keine 1″)

    Als drittes Argument der Wenn Funktion wird der Fall definiert, wenn die Wahrheitsprüfung das Ergebnis FALSCH liefert. Im angegebenen Beispiel würde der Satz „Nein, in Zelle B3 steht keine 1“ nur ausgegeben werden, sobald B3 einen anderen Wert als 1 beinhaltet und der Wahrheitstest somit ein FALSCH als Ergebnis liefern würde.

Häufig gestellte Fragen und Probleme zur WENN Funktion

  1. Was ist die Wenn Dann Funktion in Excel?

    Was ist die Excel WENN Funktion?

    Die Excel WENN Funktion in Excel, oder auch „Wenn Dann Funktion“ genannt, ist eine der am meisten verwendeten Funktionen in Excel. Sie ermöglicht logische Vergleiche oder Tests in Excel durchzuführen. Die Excel WENN Funktion kann zwei mögliche Ergebnisse ausgeben. Das erste mögliche Ergebnis wird ausgegeben, sobald der logische Test mit WAHR beantwortet werden kann. Sobald ein Test oder ein Vergleich von Werten ein negatives Ergebnis, also FALSCH, ausgibt, so kann ein Ergebnis für diesen Fall angezeigt werden.
    Eine WENN Funktion kann somit zwei mögliche Ergebnisse haben. Das erste Ergebnis wird ausgegeben, wenn der Wahrheitstest WAHR ergibt, das zweite, wenn der Test FALSCH ergibt.

  2. Wo finde ich die WENN Funktion in Excel?

    Bei der WENN Funktion in Excel handelt es sich um eine logische Funktion. Im Menüband findet man diese Funktion in der Registerkarte „Formeln“ in der Funktionsbibliothek unter „Logisch“ vor. Die Funktion kann auch direkt in eine Zelle eingegeben werden. Die Funktionseingabe startet mit einem Gleichheitszeichen, gefolgt vom Funktionsname WENN. Die WENN-Funktion erfordert nach einer öffnenden Klammer mindestens zwei Argumente. Als erstes wird ein Wahrheitstest definiert, gefolgt von zwei Argumenten die jeweils das Ergebnis bei einer wahren oder falschen Wahrheitsprüfung ausgeben.

  3. Wie funktioniert die Wenn Dann Funktion in Excel?

    Die Wenn Dann Funktion führt einen Wahrheitstest durch. Zum Beispiel wird zunächst geprüft, ob der Wert zweier Zellen identisch ist. Beispiel: A1=B1 stellt eine Wahrheitsprüfung dar. Im zweiten Schritt wird definiert, was zu tun ist, wenn dieser Wahrheitstest wahr oder falsch ist. Ist der Test positiv, also WAHR, dann wird das „Wert_wenn_wahr“ Argument in der Wenn Funktion ausgegeben. Zum Beispiel kann ein Text ausgegeben werden: „Ja, die Zellen sind gleich“. Ansonsten wird ein „Wert_wenn_falsch“ Argument definiert: „Nein, die Zellen sind nicht gleich“. In der Formelsyntax in Excel sieht das Beispiel in einer Zelle wie folgt aus:
    =WENN(A1=B1;“Ja, beide gleich“;“Leider nicht gleich“).
    Wird für „Wert_wenn_falsch“ nichts angegeben, dann gibt die Excel WENN Funktion ein FALSCH als Ergebnis aus, sobald die Wahrheitsprüfung fehlschlägt.

  4. Wie können mehrere Bedingungen in einer Wenn Dann Funktion verwendet werden?

    Wie können mehrere Bedingungen in einer WENN DANN Funktion verwendet werden?

    Um mehrere Bedingungen in einer Excel WENN Funktion unterzubringen, bedarf es weiterer logischer Funktionen für den Wahrheitstest. Häufig bietet es sich an, mit der UND sowie ODER-Funktion mehrere Bedingungen im Wahrheitstest einer Wenn-Funktion abzufangen. Ein einfaches Beispiel einer WENN Funktion mit mehreren Bedingungen kann wie folgt aussehen:

    =WENN(ODER(A1=1;A1=2);“Zelle A1 enthält den Wert 1 oder 2“;“Zelle A1 enthält keine 1 und auch keine 2“))

    Kopiere diese Formel in eine Zelle auf einem leeren Arbeitsblatt (nicht in Zelle A1!) und ändere den Wert in Zelle A1.

  5. Was ist eine verschachtelte WENN Funktion?

    Was ist eine verschachtelte WENN Funktion?

    Bei einer verschachtelten Funktion werden in einer WENN Funktion weitere solcher WENN Funktionen eingebunden. So können in Excel mehrere WENN Funktionen in einer Zelle untergebracht werden. Auf diese Weise fängt die WENN Funktion mehrere Bedingungen ab, je nachdem wie ein Wahrheitstest ausfällt. Ein einfaches Beispiel einer verschachtelten WENN Funktion lautet:

    =WENN(A1=1;“Zelle A1 enthält den Wert A1“;WENN(A1=2;“Zelle A1 enthält den Wert 2“;“Zelle A1 enthält keine 1 und auch keine 2“))

    Kopiere diese Formel in eine Zelle auf einem leeren Arbeitsblatt (nicht in Zelle A1!) und ändere den Wert in Zelle A1. Verschachtelte WENN-Funktionen lassen sich je nach Anwendungsfall mit der WENNS Funktion vermeiden.

  6. Wie kann die Farbe einer Zelle mit der Wenn Funktion geändert werden?

    Wie kann die Farbe in einer Zelle mit der WENN Funktion verändert werden?

    Eine Füllfarbe für eine Zelle kann nicht direkt aus der WENN Funktion heraus bestimmt werden. Um die Farbe einer Zelle basierend auf einer Bedingung zu verändern, muss die sogenannte bedingte Formatierung auf eine Zelle angewendet werden. Wähle dazu aus dem Startmenü aus den Formatvorlagen den Befehl „Bedingte Formatierung“. Die Excel WENN Funktion kann nur als Helferfunktion dienen, um andere Zellen über die bedingte Formatierung einzufärben.

  7. Wie kann in Excel ein Wert aus einer anderen Tabelle übernommen werden, wenn eine Bedingung zutrifft?

    SVERWEIS - Schritt für Schritt erklärt

    Für diesen Fall ist die Excel WENN Funktion nicht geeignet. Verwende dazu eine Verweisfunktion wie zum Beispiel den SVERWEIS. In diesem Artikel erfährst Du mehr zum SVERWEIS: Hier geht es zum SVERWEIS.

Weitere Tipps zur WENN Funktion

Wenn Du etwas auf Bedingungen basiert zählen möchtest, dann verwende die ZÄHLENNWENN oder ZÄHLENWENNS Funktion. Summen, die auf einer Bedingung basieren, können mit SUMMEWENN oder SUMMEWENNS gebildet werden.

Verwendest Du die WENN Funktion als Matrixformel, dann wertet die WENN Funktion jedes Argument aus der Matrix aus. Achte darauf die Matrixformel mit STRG+UMSCHALT+Eingabe zu bestätigen.

Es werden dann die geschweiften Klammern um die Formel gesetzt. Ab Excel Version 365 werden Matrizen automatisch erkannt und können ohne die spezielle Eingabe gesetzt werden. Bei einer Matrix handelt es sich um einen Zellbereich.

EXCEL LERNEN


Du möchtest Excel lernen? In unserem Kurs zu den Excel Grundlagen kannst Du Dir viele andere Funktionen ausführlicher ansehen und lernen. Außerdem findest Du dort auch Übungen zu weiteren Funktionen. Du lernst auch ausgiebiger wie Du Dich mir Dir noch unbekannte Funktionen in Excel schnell vertraut machen kannst. Erfahre mehr auf der Kursseite zum Excel Basiskurs.

Weitere Informationen zu der hier gezeigten Funktion findest Du übrigens auch auf der Hilfeseite von Microsoft.

Scroll to Top