WENNFEHLER Cover

Excel WENNFEHLER Funktion einfach erklärt

Mit der Excel WENNFEHLER Funktion können Fehler in einer Formel abgefangen werden und durch einen selbst bestimmten Wert ersetzt werden. Tritt kein Fehler auf, dann wird das erwartete Ergebnis der Formel ausgewertet und ausgegeben.

Excel WENNFEHLER Funktion einfach erklärt

Beschreibung der WENNFEHLER Funktion

Die Excel WENNFEHLER Funktion gibt einen benutzerdefinierten Wert zurück, wenn ein Ausdruck einen Fehlerwert liefert. Andernfalls wird das Ergebnis des Ausdrucks zurückgegeben. Folgende Fehlerwerte werden von der WENNFEHLER Funktion abgefangen:

  • #NV
  • #WERT!
  • #BEZUG!
  • #DIV/0!
  • #ZAHL!
  • #NAME?
  • #NULL!

Die Formelsyntax der WENNFEHLER Funktion in Excel sieht wie folgt aus:

=WENNFEHLER(Wert; Wert_falls_Fehler)

Die Variablen oder Argumente der Excel WENNFEHLER Funktion lassen sich wie folgt beschreiben:

VariableBeschreibung
Wert (erforderlich)Ein Wert, Zellbezug oder Funktion, die auf Fehlerwerte geprüft werden soll.
Wert_falls_Fehler (erforderlich)Der Wert, der zurückgegeben werden soll, wenn ein Fehler auftritt.

So wendest Du die WENNFEHLER Excel Funktion richtig an:

Excel WENNFEHLER Funktion Anleitung - Schritt 4

Mit der Excel WENNFEHLER Funktion kannst Du Fehler in einer Formel abfangen. Tritt ein Fehler auf, kannst Du diesen durch einen selbst bestimmten Wert ersetzen. Tritt kein Fehler auf, dann wird das erwartete Ergebnis Deiner Formel ausgewertet und ausgegeben. Erfahre in dieser Anleitung wie es funktioniert, Schritt für Schritt am Beispiel erklärt.

Aufwand: 2 Minuten

  1. Funktionsname WENNFEHLER eingeben

    Excel WENNFEHLER Funktion Anleitung - Schritt 1

    Beispiel: = WENNFEHLER (
    Formeln starten immer mit einem Gleichheitszeichen und signalisieren Excel die Ausführung einer Rechenoperation.

  2. Ersten Wahrheitstest formulieren

    Excel WENNFEHLER Funktion Anleitung - Schritt 2

    =WENNNV(Wert;
    Beispiel: =WENNFEHLER(C6/D6;
    Definiere einen Wert, eine Funktion oder Zellbezug welcher auf einen Fehler überprüft werden soll. Im Beispiel wird eine einfache Division durchgeführt. In der Abbildung werden Werbekosten durch die Neukunden dividiert. Im nächsten Schritt wird bestimmt, was passieren soll, wenn der ein Fehler auftritt. Ein naheliegender Fehler in diesem Szenario ist der Fall dass Division mit dem Wert 0 auftritt. Es würde ein #DIV/0! Fehler auftreten.

  3. Rückgabewert für Fehler definieren

    Excel WENNFEHLER Funktion Anleitung - Schritt 3

    = WENNFEHLER (Wert; Wert_falls_Fehler)
    Beispiel: =WENNFEHLER(C6/D6;”keine Neukunden”)
    Im nächsten Schritt wird ein Rückgabewert festgelegt, welcher ausgegeben wird, sobald der Wert in einen Fehler mündet. Im Beispiel wird angegeben, dass der Text „keine Neukunden“ ausgegeben wird, sobald der angegebene Wert, in diesem Fall eine einfache Division, einen Fehler liefert. Im vorliegenden Fall tritt inhaltlich sehr wahrscheinlich nur der Fehler auf, dass eine Division durch Null stattfindet. Im Fehlerfall wird immer „keine Neukunden“ angezeigt.

  4. Formel nach unten ausfüllen und prüfen

    Excel WENNFEHLER Funktion Anleitung - Schritt 4

    Im nächsten Schritt kann die Fehlermeldung noch angepasst werden. Im vorangegangenen Beispiel wurde immer „kein Neukunde“ ausgegeben. Sollte aber ein Anwender versehentlich Text in die Neukundenspalte schreiben, dann würde immer noch „keine Neukunden“ angezeigt werden. In diesem Fall ist der Fehler aber keine Division durch Null (#DIV/0!), sondern ein #WERT! Fehler. Die Anzahl der Neukunden muss als Zahl eingegeben werden. Der Wert_falls_Fehler kann daher natürlich auch allgemeiner formuliert werden.

Häufig gestellte Fragen zur WENNFEHLER Funktion

  1. Was ist der Unterschied zwischen der WENNFEHLER- und der WENNNV Funktion?

    Die Excel WENNFEHLER Funktion fängt mehrere verschiedene Fehlerwerte ab. Solche Fehlerwerte sind:
    #NV, #WERT!, #BEZUG!, #DIV/0!, #ZAHL!, #NAME?, #NULL! .
    Die WENNNV Funktion fängt lediglich den #NV Fehler ab. Es wird empfohlen die WENNNV Funktion bei Verweisfunktionen einzusetzen. So wird sichergestellt nur auf die Verfügbarkeit von Werten bei einer Nachschlagefunktion wie der SERWEIS-Funktion zu schauen. Die WENNFEHLER Funktion deckt mehrere Fehlerwerte ab und es ist nicht ersichtlich auf Grund welchen Fehlers ein Alternativwert ausgegeben wurde.

Bewährte Methoden zur Excel WENNFEHLER Funktion

Die Excel WENNFEHLER Funktion bietet sich bei allen möglichen Berechnungen an, die möglicherweise auch mal einen Fehlerwert liefern. Die WENNNV Funktion sollte bei Verweisfunktionen eingesetzt werden.
Eine Möglichkeit die Excel WENNFEHLER Funktion sinnvoll in Deinen Formeln einzusetzen ist, als Standardrückgabewert einen Text oder leeren Text (““) auszugeben. Das sollte je nach Anwendungsfall entschieden werden.
Das folgende Beispiel zeigt einen Alternativtext bei Fehlerwerten.

=WENNFEHLER(A1/B1;“Bitte Berechnung überprüfen“)

Das folgende Beispiel zeigt, wie gar keine sichtbare Meldung mit an den Betrachter aussieht:

=WENNFEHLER(A1/B1;““)

Wenn Wert_falls_Fehler als leere Zeichenfolge (“”) definiert wird, wird dem Betrachter keine Nachricht angezeigt.

Excel lernen


Du möchtest Excel lernen? In unserem Kurs zu den Excel Grundlagen kannst Du Dir viele andere Funktionen ausführlicher ansehen und lernen. Außerdem findest Du dort auch Übungen zu weiteren Funktionen. Du lernst auch ausgiebiger wie Du Dich mir Dir noch unbekannte Funktionen in Excel schnell vertraut machen kannst. Erfahre mehr auf der Kursseite zum Excel Basiskurs.

Weitere Informationen zu der hier gezeigten Funktion findest Du übrigens auch auf der Hilfeseite von Microsoft.

Scroll to Top