SVERWEIS Excel - Video Anleitung

SVERWEIS Funktion in Excel

Mit der Funktion SVERWEIS kannst Du Werte in Excel „nachschlagen“. Mit anderen Worten kann das mit der Suche nach einer Telefonnummer in einem Telefonbuch verglichen werden. Zum Beispiel suchst Du nach einem bestimmten Namen (Suchkriterium) im Telefonbuch. Anschließend suchst Du entsprechend in der daneben stehende Spalte die nebenstehende Telefonnummer.

Im Grunde genommen macht das gleiche die SVERWEIS Excel Funktion für Dich auch.
Schaue Dir die SVERWEIS Funktion im folgenden Video an. Weiter unten findest Du auch noch eine Datei mit Übungen zum SVERWEIS und den Inhalten aus dem SVERWEIS Beispiel-Video.

Der SVERWEIS in Aktion

YouTube

Mit dem Laden des Videos akzeptieren Sie die Datenschutzerklärung von YouTube.
Mehr erfahren

Video laden

Beispiel und Übung zur SVERWEIS Funktion

Im Folgenden kannst Du Dir die Übung und die Inhalte aus dem Video runterladen.

Beschreibung der Funktion SVERWEIS

Die SVERWEIS Excel-Funktion gehört zu den Nachschlage- sowie Verweisfunktionen in Excel. Mit dieser Funktion kannst Du Einträge in einem Datensatz oder einem Bereich absuchen. Anschließend wird ein dazugehöriger Wert zurückgegeben. Das „S“ in SVERWEIS steht für senkrecht. Bei dem Suchvorgang wird in der ersten Spalte (senkrecht, von oben nach unten) eines Bereiches nach einem Wert gesucht. Im Englischen heißt diese Funktion VLOOKUP wobei das V für „vertical“ steht.

Klassische Beispiele für die SVERWEIS Excel-Funktion sind:

  • Du möchtest für einen Mitarbeiternamen Informationen wie Gehalt sowie Position aus einer großen Liste ausgegeben haben.
  • Dir liegen viele Produktnummern vor. Entsprechend möchtest Du aus einer großen Liste den Warenbestand in einer neuen Liste zusammenfassen.

Das Anwendungsgebiet ist sehr flexibel sowie breit gefächert.

Die grundlegende Formelsyntax sieht wie folgt aus:

=SVERWEIS(Suchkriterium; Matrix; Spaltenindex; [Bereich_Verweis])

Umgangssprachlich formuliert lässt sich die SVERWEIS Excel-Funktion in Ihrer Logik und Anwendung folgendermaßen beschreiben:

VariableBedeutung (umgangssprachlich)
Suchkriterium
(erforderlich)
Der Nachschlage-Wert nach dem gesucht werden soll.
Matrix
(erforderlich)
In welchem Zellbereich soll nachgeschlagen werden.
Spaltenindex 
(erforderlich)
Welche Spaltennummer enthält die gesuchte Information.
Bereich_Verweis 
(optional)
Genaue Übereinstimmung oder ungefähre Übereinstimmung zum nachgeschlagenen Wert– angegeben als “0“ oder „FALSCH” oder “1“ oder „WAHR”

SVERWEIS Excel: Formel-Syntax

Die Formelsyntax für die SVERWEIS Excel-Funktion sieht folglich so aus:

=SVERWEIS(Suchkriterium; Matrix; Spaltenindex; [Bereich_Verweis])
ParameterBeschreibung
Suchkriterium
(erforderlich)
Der Wert, nach dem gesucht werden soll.
WICHTIG: Der gesuchte Wert muss sich in der ersten Spalte des Zellbereichs befinden, der im nächsten Argument als Matrix definiert wird.

Wenn die Matrix z.B. die Zellen C2:E6 umfasst, muss sich das Suchkriterium in Spalte C befinden. Das Suchkriterium kann ein Wert (z.B. Text oder Zahl) sowie ein Bezug auf eine Zelle sein.
Matrix
(erforderlich)
Das ist der Zellbereich, in dem SVERWEIS nach dem Suchkriterium und dem gewünschten Rückgabewert aus dem Spaltenindex (siehe nächster Parameter) sucht.

Die hier angegebene Matrix muss das zu suchende Nachschlagewort (Suchkriterium) in der ersten Spalte führen. Damit die SVERWEIS Funktion auch einen Rückgabewert liefern kann, muss der Rückgabewert auch innerhalb der angegebenen Matrix liegen.
Spaltenindex 
(erforderlich)
Das ist die Spalte in der Matrix, die den gewünschten Rückgabewert liefert. Die Nummerierung der Spalten beginnt bei 1.
Bereich_Verweis 
(optional)
An dieser Stelle gibst Du an, ob Excel nach einer genauen oder einer ungefähren Übereinstimmung sucht. Wird hier kein Wert angegeben, wird automatisch WAHR für eine ungefähre Übereinstimmung angenommen.

WAHR/1: setzt voraus, dass die erste Spalte in der Tabelle entweder nach Zahlen (numerisch) oder alphabetisch sortiert ist. Es wird dann nach dem am nächsten liegenden Wert gesucht.

FALSCH/0: sucht nach dem exakten Wert in der ersten Spalte der Matrix.

Anleitung zur SVERWEIS Funktion

Sverweis Anleitung - Schritt für Schritt

Sverweis Anleitung – Schritt für Schritt

Gesamtzeit: 2 Minuten

  1. Gleichheitszeichen setzen

    Formel mit einem Gleichheitszeichen starten.

    Formel mit einem “Istgleich-Zeichen” in einer Zelle starten: =
    Formeln starten immer mit einem Gleichheitszeichen und signalisieren Excel die Ausführung einer Rechenoperation.

  2. Funktionsname eingeben und Klammer öffnen

    Funktion eingeben und anschließend vier Funktionsparameter übergeben.

    SVERWEIS eingeben: =SVERWEIS(
    Die SVERWEIS Funktion verlangt vier Funktions-Parameter, welche in den nächsten Schritten erläutert werden.

  3. SVERWEIS Suchkriterium: Den suchenden Wert eingeben

    Suchkriterium definieren

    =SVERWEIS(Suchkriterium
    Beispiel: =SVERWEIS(C15;
    Die SVERWEIS Funktion wird nun nach dem hier angegeben Wert (hier der Wert aus Zelle C15) in der ersten Spalte der Suchmatrix (nächster Schritt) suchen. Im gezeigten Beispiel wird nach dem Namen “Angie” gesucht.

  4. Matrix definieren

    Such-Matrix definieren

    =SVERWEIS(Suchkriterium; Matrix
    Beispiel: =SVERWEIS(C15;B7:D13;
    In diesem Schritt wird die Matrix definiert in der nach dem Suchkriterium gesucht wird. Im vorliegenden Beispiel wird nach dem Wort “Angie” in der ersten Spalte der Matrix gesucht. Im nächsten Schritt wird der Rückgabewert über den Spaltenindex bestimmt.

  5. Spaltenindex angeben

    SVERWEIS Spaltenindex für den Rückgabewert definieren

    =SVERWEIS(Suchkriterium; Matrix; Spaltenindex
    Beispiel: =SVERWEIS(C15;B7:D13;3
    In diesem Beispiel wird nun der Wert aus Zelle C15 im Zellbereich B7:D13 innerhalb der ersten Spalte gesucht. Anschließend wird der Wert aus der dritten Spalte, dem Spaltenindex, in der Zeile des gesuchten Wertes zurückgegeben. Achtung: Der Spaltenindex bezieht sich auf die Anzahl der Spalten der Matrix. Als Ergebnis wird in diesem Beispiel ein Umsatzwert als Ergebnis zurückgegeben.

  6. Für Bereich_Verweis WAHR oder FALSCH angeben

    genaue oder ungefähre Übereinstimmung definieren

    =SVERWEIS(Suchkriterium; Matrix; Spaltenindex; [Bereich_Verweis)
    Beispiel: =SVERWEIS(C15;B7:D13;3;FALSCH)
    In diesem Schritt wird mit WAHR oder FALSCH bestimmt ob eine exakte (FALSCH) oder eine ungefähre Übereinstimmung zum Suchwert in der ersten Spalte der Matrix angewendet soll. In diesem Beispiel wird mit FALSCH eine exakte Übereinstimmung erzwungen. Das heißt, dass nur ein Rückgabewert oder Ergebnis ausgegeben wird, wenn das Suchkriterium im exakten Wortlaut gefunden wurde.
    Im Beispiel Video zum SVERWEIS auf dieser Seite findest Du auch ein Beispiel für die ungefähre Übereinstimmung.

  7. Funktionseingabe bestätigen

    vollständiges Beispiel

    Nachdem die vollständige Formel eingegeben und bestätigt wurde, wird in diesem Beispiel der Umsatz für “Angie” zurückgegeben. Du kannst den Suchwert in Zelle C15 auch zum Beispiel in “Marvis” ändern und würdest anschließend das Ergebnis 91.605 € in Zelle C16 erhalten.
    Diese Beispieldatei kannst Du Dir auch auf dieser Seite runterladen, um mit den Beispieldaten den SVERWEIS zu üben. Es sind auch Übungsaufgaben zum SVERWEIS enthalten.

Häufig Gestellte Fragen und Probleme mit der SVERWEIS Funktion

Trotz aller Sorgfalt kann die SVERWEIS Excel- Funktion schnell zu Fehlern führen. Auf jeden Fall solltest Du Deinen Datensatz gut kennen und auf eine korrekte Schreibweise achten.

Hier findest Du einige Fragestellungen und häufig auftretende Probleme.

  1. Der SVERWEIS gibt einen falschen Wert zurück.

    falsches Ergebnis

    Wenn Du für Bereich_Verweis keinen Wert definiert hast wird automatisch WAHR angenommen. Das entspricht der ungefähren Übereinstimmung und kann zu fehlerhaften Ergebnissen führen. Du solltest die erste Spalte der Suchmatrix auf jeden Falls alphabetisch oder numerisch sortieren. Sortiere also die erste Spalte oder wende den Parameter FALSCH an, damit die SVERWEIS Funktion nach dem exakten Inhalt sucht.

  2. Warum gibt die SVERWEIS als Ergebnis #NV zurück?

    SVERWEIS gibt #NV zurück

    Ganz kurz beantwortet: #NV bedeutet soviel wie “nicht verfügbar” und die Funktion konnte keinen Wert als Ergebnis ermitteln. Ein möglicher Grund ist, dass Du für Bereich_Verweis “WAHR” angegeben hast und der Wert im Suchkriterium kleiner als der kleinste Wert in der ersten Spalte in der Matrix ist.
    Stelle sicher dass die Suchmatrix in der ersten Spalte sortiert wurde.
    Wenn Du für den Bereich_Verweis FALSCH angegeben hast, dann zeigt der Fehlerwert “#N/A” an, dass keine Überinstimmung mit dem Suchkriterium in der ersten Spalte gefunden wurde.

  3. Warum gibt der SVERWEIS den Fehler #BEZUG zurück?

    SVERWEIS gibt #BEZUG als Fehler zurück

    Dieser Fehler tritt häufig auf, wenn Du zum Beispiel als Spaltenindex 4 angibst, aber Deine Matrix nur 3 Spalten breit ist. Du suchst in diesem Fall in einem nicht definierten Bereich und Excel kann keinen Bezug mehr für die SVERWEIS Funktion herstellen. Der Fehler #BEZUG! wird zurückgegeben, da der Spaltenindex größer als die Spalten-Anzahl der Matrix ist.

  4. Warum gibt der SVERWEIS als Ergebnis #WERT zurück?

    #WERT als Ergebnis

    Diese Fehlermeldung kann bei Tippfehlern auftreten, zum Beispiel wenn die Matrix oder der Spaltenindex kleiner als 1 ist. Prüfe ob Deine Formel auch wirklich korrekt sind, wie beispielsweise richtig angewendete Zellbezüge und Rechtschreibung.

  5. Warum gibt der SVERWEIS als Ergebnis #NAME zurück?

    #NAME als Fehler

    Eine häufige Fehlerquelle für diesen Fehler liegt im Suchkriterium. Wenn Du zum Beispiel nach einem Namen suchst, dann muss dieser korrekt in Anführungszeichen gesetzt werden. Dieses Problem kannst Du umgehen, indem Du das Suchkriterium über einen Zellbezug definierst.
    Beispiel Suchkriterium als Text in der Funktion:
    =SVERWEIS(„Angie“;B7:D13;3;FALSCH)
    Beispiel Suchkriterium mit Zellbezug: C15=Angie
    =SVERWEIS(C15;B7:D13:C5;3;FALSCH)
    Mit einem Bezug zu einer anderen Zelle mit dem Suchkriterium fällt die Fehlersuche unter Umständen etwas einfacher aus. Ein Schreibfehler in Zelle C15 würde in diesem Beispiel jedoch auch zu einem Fehler führen.

Bewährte Methoden zur Anwendung von SVERWEIS

Im Folgenden findest Du einige Empfehlungen, welche Dich bei der korrekten Anwendung bei der SVERWEIS Funktion unterstützen.

EmpfehlungErklärung
Verwendung absoluter ZellbezügeMit der Verwendung absoluter Zellbezüge können Fehler beim Ausfüllen der Formeln vermieden werden. Zum Beispiel bietet es sich an die Matrix immer in absoluten Zellbezügen zu führen. Im Beispiel sieht das folgendermaßen aus:
=SVERWEIS(A1;$A$3:$C$5;3;FALSCH)
Die Dollarzeichen ($) fixieren den Matrix-Bereich. Je nach Anwendungsfall empfiehlt es sich auch das Suchkriterium zu fixieren. Es gibt keine eindeutige Empfehlung für die Verwendung der Zellbezüge. Müssen Formeln in einer Liste nach unten ausgefüllt werden, sind absolute Zellbezüge in der Regel notwendig. Die Dollarzeichen verhindern beim Kopieren der Formel ein Verrutschen der Zellbezüge. Mehr Infornmationen dazu findest Du auch im Beispiel Video zum SVERWEIS.
Werte korrekt formatierenWenn nach Datumswerten oder Zahlen gesucht wird, solltest Du sicherstellen, dass das Zellformat in der Suchspalte (erste Spalte der Matrix) die korrekte Formatierung aufweist. Suchst Du zum Beispiel nach einem Datum, aber das Datum ist als Text formatiert, dann wird SVERWEIS nicht korrekt funktionieren.
Erste Spalte sortierenFür den Fall, dass Du nach einer ungefähren Übereinstimmung (Bereich_Verweis ist WAHR) suchst, dann solltest Du die Matrix nach der ersten Spalte sortiert sein.
Kenne Deine Daten!Einfacher gesagt als getan! Erhältst Du einmal Fehler mit der Excel SVERWEIS Funktion, dann bietet es sich an die erste Spalte der Suchmatrix genauer zu prüfen. Wenn Sich hier Fehler oder andere Zellformate sowie Zeichen eingeschlichen haben, kann SVERWEIS zu unerwarteten Ergebnissen führen.

Excel lernen


Du möchtest Excel lernen? In unserem Kurs zu den Excel Grundlagen kannst Du die Grundlagen zu Excel erlernen. Die SVERWEIS Excel-Funktion ist kein Bestandteil dieses Kurses, aber Du lernst dort viele Grundlagen zu Excel, wie zum Beispiel Zellbezugsarten, die allgemeine Anwendung von Funktionen und vieles mehr.

Du findest ebenfalls weiter führende Informationen zum SVERWEIS auf den Hilfeseiten von Microsoft.

Scroll to Top